Linked by intric8 on Thu 12th Oct 2017 21:19 UTC
Amiga & AROS

A "new" piece of software, quietly created 15 years ago, that allows Amiga 1000 users to load their Kickstart 1.3 or 3.1 (or "morph" between the two on a soft reset after loading 3.1) off a single disk has been discovered. The software is called TwinKick and is downloadable via Aminet. The linked post includes detailed instructions on how to create this disk.

Being able to switch between the two Kickstarts is pretty incredible. Although seeing 3.1 load onto a Amiga 1000 - off a floppy - is pretty mind blowing by itself.

Order by: Score:
Comment by fx__
by fx__ on Fri 13th Oct 2017 07:55 UTC
fx__
Member since:
2006-03-31

I wonder if the person who wrote that article has ever used an amiga seriously.

"99.9% of all Amiga software was written not just to work on 1.3, but was aimed directly at it."

That is just inaccurate. I tried to setup a Workbench 1.3 installation some time ago and it was a pain trying to find programs that could run on 1.3, I had to search trough old fish-disks to find utilitites that could work with 1.3. Almost everything required 2.x or newer since there where some huge changes between 1.3 and 2.x.

Reply Score: 3

RE: Comment by fx__
by intric8 on Fri 13th Oct 2017 15:39 UTC in reply to "Comment by fx__"
intric8 Member since:
2016-12-10

@ fx__ From a public domain perspective you may be correct. From a commercial software perspective I think the author is accurate. 1.3 hit the widest market and if coded properly those running 3.1 could also utilize most 1.3 software just fine. Only the really old stuff for 1.3 (from the 80s) seemed to have issues on 3.1 in my experience. Again, from a commercial software perspective.

Edited 2017-10-13 15:49 UTC

Reply Score: 3

RE[2]: Comment by fx__
by daedalus on Fri 13th Oct 2017 20:14 UTC in reply to "RE: Comment by fx__"
daedalus Member since:
2011-01-14

Hmmmm, most decent software received updates or was replaced over the years with versions requiring the newer OS versions. There are very few packages I can think of that still ran on KS 1.3 in the mid-late '90s - maybe Scala? Anyway, 99.9% is a ridiculous exaggeration.

Reply Score: 3

A500+
by henderson101 on Fri 13th Oct 2017 08:35 UTC
henderson101
Member since:
2006-05-30

I own an old A500+ (that may or may not work - it did last time I tried to use it a few years ago.) A mate's brother had a regular 500 and he made me a boot disk to boot in to Kickstart 1.3 (500+ comes with Kickstart 2.0.) It allowed a few games to work that didn't otherwise. It was pretty cool. I'm guessing htis is a variation of that software for the A1000.

I'd like to try running Kickstart 3.0 on the 500+ so I might look at that possibility at some point.

Reply Score: 3

RE: A500+
by intric8 on Fri 13th Oct 2017 15:48 UTC in reply to "A500+"
intric8 Member since:
2016-12-10

@ henderson101 A friend of mine keyed me into a similar piece of software as mentioned in the article above for A1000's but for 500/2000's called the "Amiga 500/2000 kick reset program". It did a very similar thing. There is a snazzy intro on YouTube that was apparently part of it and gives more info in the scroller:
https://www.youtube.com/watch?v=F7rmpNcxUEo

I've not found that software personally.

Edited 2017-10-13 15:49 UTC

Reply Score: 2

RE: A500+
by daedalus on Fri 13th Oct 2017 20:15 UTC in reply to "A500+"
daedalus Member since:
2011-01-14

3.0 and 3.1 both run fine on a 500+, and on a 500, though you really want more RAM in it to make full use of the newer features.

Reply Score: 3

Reverse issue
by JLF65 on Sat 14th Oct 2017 08:16 UTC
JLF65
Member since:
2005-07-06

Many MANY years back when I got my Amiga 500, I had the reverse problem - many games required KS 1.0/1.1, especially early EOA games like Seven Cities of Gold and Archon. So I made a boot disk that loaded KS 1.0 or 1.1 into the upper part of chip ram or bogo ram if available, then patched it to run at the new address. Worked great for those old games.

Reply Score: 3