Linked by Thom Holwerda on Fri 20th Feb 2009 15:49 UTC, submitted by Michael
Benchmarks "Earlier this month we published an article looking at the Linux versus OpenSolaris performance when using the new AMD Shanghai Opteron CPUs. Ubuntu Linux was faster than OpenSolaris 2008.11 in nearly all of the tests, but as mentioned in that article, OpenSolaris is still dependent upon GCC 3.4 where as Ubuntu and most other Linux distributions are now shipping with the newer and much-improved GCC 4 series. Following that article being published, Sun Microsystems had requested some compiler tests since they were confident the results would be different had their Sun Studio compiler been used. Well, in this article we now have some OpenSolaris benchmarks from the same AMD setup using GCC 3.4, GCC 4.0, and Sun Studio 12."
Permalink for comment 350014
To read all comments associated with this story, please click here.
GCC 4.0.2
by jacquouille on Fri 20th Feb 2009 17:03 UTC
jacquouille
Member since:
2006-01-02

I stopped reading here.

What's the point of benchmarking GCC 4.0.2 in 2009?

GCC 4.1 was a big improvement over GCC 4.0.
GCC 4.2 was a big improvement over GCC 4.1.
GCC 4.3 was a big improvement over GCC 4.2.

GCC 4.3 was released one year ago. Even debian stable has it. GCC 4.4 is nearing release and is an especially important upgrade.

I can't see any reason why one would want to benchmark GCC 4.0 in 2009 except trying to make GCC4 look bad, or at least, less impressive than it really is.

If any OS is still stuck at GCC 4.0, all that means is that you can't use this OS to benchmark GCC4 in 2009, end of the story. That's by no means an excuse to publish a "GCC4" benchmark without at least a very prominent notice that "This benchmark is of course irrelevant because we tested a GCC version that's completely outdated".

EDIT: I read a bit the article, and there's a small mention of that fact on page 6, but that's not enough for something that makes the whole benchmark totally irrelevant (since the other gcc benchmarked here, 3.4, is even more outdated)

Edited 2009-02-20 17:10 UTC

Reply Score: 4