Linked by Thom Holwerda on Thu 30th Apr 2009 20:42 UTC
OpenBSD The OpenBSD team has released OpenBSD 4.5. There have been lots of changes and bug fixes, but it's a rather daunting list that doesn't really lend itself towards a summary (hint), but I guess if you use OpenBSD you are perfectly capable of figuring this out yourself. You can get the new release from the download page.
Permalink for comment 361119
To read all comments associated with this story, please click here.
Comment by darknexus
by darknexus on Fri 1st May 2009 00:18 UTC
darknexus
Member since:
2008-07-15

Coding wasn't the main holdback of WPA in OpenBSD. Many of the top developers didn't want WPA implemented for a while, giving the reason that WPA wasn't anywhere near as secure as IPSEC or an OpenVPN-based setup. In their minds, that was what any respectable user should be using... and for a large infrastructure, imho, they're absolutely right, but a lot of users didn't need or want to deal with that or needed to connect to WPA-enabled networks. . They only relented a few releases back (4.3 is when the initial code for WPA began to be integrated), and that's what I'm referring to when I say they were being pigheaded about the issue. There would've been no point coding WPA for OpenBSD if Theo and the rest of the top people were going to reject it.

Reply Score: 2