Linked by Jordan Spencer Cunningham on Fri 14th Aug 2009 02:29 UTC
Linux It's the end of the world. Again. According to some Linux developers and security researchers, a bug in the Linux kernel has just been uncovered that makes just about every distribution utilizing kernel 2.4 and 2.6 on just about all architectures since May of 2001 vulnerable to a certain kind of attack.
Permalink for comment 378494
To read all comments associated with this story, please click here.
RE[2]: WinXP
by _xmv on Fri 14th Aug 2009 09:43 UTC in reply to "RE: WinXP"
_xmv
Member since:
2008-12-09

That's not quite true. Bugs that are not *public* might and are often already discovered and exploited by a few individuals only. It can stay like this for years.
There's not much you can do against it.
You can scratch your design and make one less bug-prone, or invent something no one else thought about that's 100% secure (good luck with that)
Meanwhile we patch and do our best to make things as secure as possible


edit: note that this is 100% true with Windows, MacOSX and what-not as well

Edited 2009-08-14 09:44 UTC

Reply Parent Score: 1