Linked by Thom Holwerda on Mon 18th Jan 2010 22:00 UTC
Internet Explorer Ah, the security vulnerability that was used in the Google attack. It's been around the internet about a million times now, and even governments have started advising people to move away from Internet Explorer. As is usually the case, however, the internet has really blown the vulnerability out of proportion. I'll get right to it: if your machine and/or network has been compromised via this vulnerability, then you most likely had it coming. No sympathy for you.
Permalink for comment 404864
To read all comments associated with this story, please click here.
Update of upgrade?
by spinnekopje on Tue 19th Jan 2010 08:35 UTC
spinnekopje
Member since:
2008-11-29

If I understand correctly the security problem also occurs on supported software. MS should deliver a solution to the companies with support contract with updates or upgrades. Companies without support should take care of that themselves.

Normal customers must take action themselves, but.. I guess about 95% of the people I know have no idea what the problem is. They just say it works, why change it? I can't blame them, they are only interested in getting their work done or the stuff they like to do.

I've read in the other comments about some settings in new windows versions. Just forget about settings, the only setting that counts is the default. When that restricts people to do what they want, all lower settings are also important. Never forget users want to get their 'work' done and really don't care about safety. After all they did what was told: do updates and use a virus scanner.

Reply Score: 2