Linked by Thom Holwerda on Sat 26th Mar 2011 02:00 UTC
Mac OS X When you run smbd -V on your Snow Leopard installation, you'll see it's running SAMBA version 3.0.28a-apple. While I'm not sure how much difference the "-apple" makes, version 3.0.28a is old. Very old. In other words, it's riddled with bugs. Apple hasn't updated SAMBA in 3 years, and for Lion, they're dumping it altogether for something homegrown. The reason? SAMBA is now GPLv3.
Permalink for comment 467928
To read all comments associated with this story, please click here.
Doth mine eyes deceive me?
by mrhasbean on Sat 26th Mar 2011 05:17 UTC in reply to "RE: Comment by Brynet"
mrhasbean
Member since:
2006-04-03

People who write software should be able to determine the circumstances under which it can be used, right?


Certainly not if it's say Apple saying "you can only run this on our hardware", but I suppose because it's GPL people view it with a different set of glasses - ones that have a rosey tinge...

Legally this is the only choice Apple has. GPLv3 is simply not compatible with large corporations, and Apple won't be the only ones distancing themselves from products that use it. While the goals of those patent clauses might seem honourable, the legal advisers to major corporations would be foolhardy to advise they do anything other than step away from such products, because taking on responsibility for someone else's patent compliance is just opening a can of worms, and certainly not something viable for big companies.

Reply Parent Score: 5