Linked by Thom Holwerda on Mon 21st May 2018 22:52 UTC
Bugs & Viruses

Microsoft and Google are jointly disclosing a new CPU security vulnerability that's similar to the Meltdown and Spectre flaws that were revealed earlier this year. Labelled Speculative Store Bypass (variant 4), the latest vulnerability is a similar exploit to Spectre and exploits speculative execution "that modern CPUs use. Browsers like Safari, Edge, and Chrome were all patched for Meltdown earlier this year, and Intel says these mitigations are also applicable to variant 4 and available for consumers to use today."

However, unlike Meltdown (and more similar to Spectre) this new vulnerability will also include firmware updates for CPUs that could affect performance. Intel has already delivered microcode updates for Speculative Store Bypass in beta form to OEMs, and the company expects them to be more broadly available in the coming weeks. The firmware updates will set the Speculative Store Bypass protection to off-by-default, ensuring that most people won’t see negative performance impacts.

This cat ain't going back in no bag anytime soon.

Permalink for comment 657137
To read all comments associated with this story, please click here.
jmorgannz
Member since:
2017-11-05

I never mentioned switching to anything, but not investigating better alternatives to a broken architecture because anything new might have unknowns, well that's stupid.

See http://www.osnews.com/story/30384/C_is_not_a_low-level_language (and associated article) for more enlightenment.

Edited 2018-05-22 13:59 UTC

Reply Parent Score: 0