posted by Carewolf on Tue 29th May 2018 20:13 UTC
Icon

Now that Qt 5.11 is released, it is finally time to upgrade the last Qt 1.0 applications out there... No, not really. I want to take a look at how well we have kept compatibility in Qt over the years since the first official release.

Qt guarantees source and binary compatibility between minor releases, and we take that seriously. Making sure that you don't have to rewrite (or even recompile) your application when you upgrade to a newer version of Qt is important to us. However, there are times when we need to make bigger changes in order to keep Qt up to date. This is done in major releases. Since the release of Qt 1.0 in 1996 (almost twenty-two years ago), we have broken source compatibility four times: in 2.0, 3.0, 4.0 (some of you may remember that as a painful transition), and 5.0.

We do try to keep breakages to a minimum, even in the major releases, but the changes do add up. This raises the question: How hard would it be to port a Qt application from Qt 1.0 to 5.11?

Not only an interesting look at Qt history, but also a look back on mid 90s C++, and what has and hasn't changed.


e p (7)    6 Comment(s)

Technology White Papers

See More