Linked by Thom Holwerda on Thu 10th Aug 2006 09:58 UTC, submitted by Philipp Esselbach
Ubuntu, Kubuntu, Xubuntu "The Ubuntu team is proud to announce the release of Ubuntu 6.06.1 LTS, the first maintenance release of "Dapper Drake". This release includes both installable Desktop CDs and alternate text-mode installation CDs for several architectures, for Ubuntu, Kubuntu and Edubuntu. Xubuntu is also included, although commercial support for it is not available from Canonical."
Thread beginning with comment 151107
To read all comments associated with this story, please click here.
I wonder if they fixed the installer?
by OMRebel on Thu 10th Aug 2006 14:03 UTC
OMRebel
Member since:
2005-11-14

Not sure about other people's experiences, but the GUI installer in Dapper needed some attention. On Monday I had to wipe Ubuntu off of my laptop and install Windows XP on it (needed XP for a class I'm taking in .NET, and couldn't ever get VMWare going). So, after installing XP, I booted off of the Dapper CD and went to install it as a dual boot machine. I went to the manual partition and told the installer to use 50% of the available space. The installer started going, but after an hour of it sitting on the partition screen, and no activity on the drive, the machine was locked up. Once I had rebooted I discovered that the partition headings were seriously hosed.

I've done fresh installs with Dapper on my laptop, without setting up the dual boot, and it worked fine. However, I'm a bit too timid to try to setup the dual boot again considering how long it takes to get everything with XP installed and secured. Has anyone else here seen the same problem with setting up the dual boot? The laptop I have is a HP n5150.

Edited 2006-08-10 14:03

Reply Score: 1

Jesuspower Member since:
2006-01-28

The graphical installer stalls on anything less than 512mb of RAM. Its terrible.
I tried partitioning on a 256MB system and it just sat there for a few hours(I had the time to watch).
The text mode install is much better than the GUI version, and makes it easier to get the install done. I just got my Dapper CDs in the mail, for distrobution at my school. I hope those have a text installer.

Reply Parent Score: 1

orestes Member since:
2005-07-06

That doesn't match my experiences.
The install I did this morning took around 20 minutes from start to finish.
That was on a VM with 256MB of ram allocated to it.

Reply Parent Score: 1

snozzberry Member since:
2005-11-14

It takes longer. I wouldn't call it stalling. I know because I did it last night on a 256Mb laptop. The initial CD startup and the partitioning are the worst offenders because they require either a lot of memory or a lot of swap patience.

Outside of those two issues, pretty good.

Broadcom wifi support, not so good. Ubuntuforums has two warring camps between bcm43xx and ndiswrapper, with plenty of wounded unhappy with both since the Dapper release broke ndiswrapper.

It isn't Ubuntu's fault that Broadcom support is native to 2.6.17, but maybe some of it could be backported.

Reply Parent Score: 1

whitehornmatt Member since:
2005-07-07

The shipit cds are the desktop ones unfortuantly

Reply Parent Score: 1

OMRebel Member since:
2005-11-14

My laptop actually has 512MB RAM in it, so I don't think memory is the problem. I think the partitioning portion of the installer has a bug in it. Like I said, if I want to wipe the entire drive clean, it'll install fine. But, if I only want to partition off 50% of the drive, then that's where it throws a fit at.

Reply Parent Score: 1

TaterSalad Member since:
2005-07-06

I had the same problem with Dapper. I went to resize some partitions to install it, and it just hung on the partitioner. I downloaded the alternate cd and did a text mode install which worked very well for me.

Reply Parent Score: 1

snozzberry Member since:
2005-11-14

The GUI partitioner is not robust. Building a Mythbox requires an XFS partition, and the Ubuntu LiveCD's GUI partitioner chokes on trying to make XFS partitions. Random combinations of partition sizes also yield failures; I resized a Windows laptop last night from 20Gb (no Windows swap, oddly) to 5Gb NTFS/100Mb FAT32/1Gb swap/remaining ext3 and it choked until I redid it with 150Mb FAT32. No real explanation why.

Fixing it needs to be a priority, even if the need for XFS is pretty unlikely.

Reply Parent Score: 1

smeat Member since:
2006-07-27

Maybe reading the linked article would have been a good idea before you start complaining about something.

TFA says:
* Fix gparted crash if xfs_db fails (#50909).

Ya think that might be the XFS bug you are talking about?


Or how about these for the other partition problems you were having:
more defence against gparted/qtparted crashing (#47194, #48856)

Reply Parent Score: 2