Linked by Thom Holwerda on Tue 26th Jun 2007 11:50 UTC, submitted by Michael
Sun Solaris, OpenSolaris "There's a problem with Solaris and Sun knows it. The installation experience of Solaris (along with other areas) could be greatly improved. The installer doesn't 'suck' as it's easy and known to Solaris administrators, but for a Linux or Windows user it could prove to be a bit challenging. For those of you that have never tried out Solaris, what we've decided to do is to show you this 'usability gap' with the installation process in Solaris compared to Linux. Is the experience really that bad?"
Thread beginning with comment 250678
To read all comments associated with this story, please click here.
From my experience ...
by Ookaze on Tue 26th Jun 2007 14:32 UTC
Ookaze
Member since:
2005-11-14

these guys had a really easy time.
I had to install Solaris 10 on x86 and Sparc for performance tests purpose, and the only thing I can tell is that I never want to do that again. While the installation on Sparc was hugely frustrating, the installation (with CD) on the x86 servers (DL380) was just unbearable. I installed countless OS, but this one was the worst of all my life. I made at least 30 installs before getting the workarounds for all the install bugs and flaws. The Solaris 10 version, though more recent than the servers, lacked the cciss driver, which made the all experienve even worse, as I had to use a floppy disk.
The normal installation, that used X, was crashing at the point of analyzing the disks (I don't know why), the console mode worked, but as I had to install the driver on floppy first, there was no way to go back to console install afterward (well, I found a way, involving Ctrl-C at some parts of it, pure hell).
I remember lots of the hell I went through : network settings not taken into account, package dependancies not automatically added, you have to add them by hand until it says there are no more dependancy problems, all of this through tedious curses (that's the same in X, only worse) menu with no quick hotkeys to parse the huge list of modules faster, password field not accepting characters like the dot which unfortunately I needed, install process that aborts after installing everything there is on the first CD, because it can't eject it, and installs the rest when the OS reboots, but only if you installed some modules, partition app completely unintuitive and messed up with a misleading process, choice of locale not taken into account, packages that I specifically asked to install that never got installed, ...

I don't even remember it all. Perhaps most of my pain was due to having to use CD instead of DVD, but I don't want to touch a Solaris 10 installation ever again.

Reply Score: 5

RE: From my experience ...
by Robert Escue on Tue 26th Jun 2007 15:09 in reply to "From my experience ..."
Robert Escue Member since:
2005-07-08

What did you specify during the installation that caused a dependency issue? Did you get updated drivers from HP before you started the install?

I actually had more trouble installing Solaris 9 on a DL360 than Solaris 10, but I also had all of HP's updated drivers.

While a Solaris x86 install is not perfect, there is also a lot to be said about being prepared to install Solaris (or any other OS) for that matter.

Reply Parent Score: 3

RE[2]: From my experience ...
by Ookaze on Tue 26th Jun 2007 19:49 in reply to "RE: From my experience ..."
Ookaze Member since:
2005-11-14

There were dependencies from the start. I selected the core install, which is supposed to have very few packages.
The basic Java dependencies necessary for the installation of the other CD after reboot wasn't selected. It worked like package management on any Linux distro, except that it didn't resolve them, and I had to do it by hand.

Reply Parent Score: 2