Linked by Thom Holwerda on Mon 27th Aug 2007 22:21 UTC
Windows A curious network performance reduction noticed by many Windows Vista users of the 2CPU forum that became the talk of Slashdot last week has been identified as having been caused not by DRM, as Slashdot users expected, but by a curious prioritization 'feature' of Vista that's intentionally biased toward Media Player at the expense of network and system resources.
Thread beginning with comment 266345
To read all comments associated with this story, please click here.
Multitasking and scheduling
by hraq on Tue 28th Aug 2007 18:38 UTC
hraq
Member since:
2005-07-06

I have tried that extensively in the past and I have found Linux to be the best in that regard.
On Ubuntu 7 or RHEL 5 or CentOS 4,5 I found I was able to move 16 GB data from it to windows server 2003 share while on the background I was watching xvid video and downloading 20 and more things from amule servers and azureus 2.5; all while I was running a "watch df" and "watch ifconfig" and running "top" on different gnome-terminal sessions with sudo previleges while downloading PC-BSD 1.3 first CD via KGet. and krdesktop to my windows server 2003. While burning 2 udf DVDs on 2 different burners one IDE and the second USB (the program used is nerolinux 3.0.0 and files to be burned are on network share).
I always keep Opera(20 tabs) and firefox (4 tabs) open in the background with auto update on.
My system is gigabyte motherboard (100$), HDD 7200rpm, 3.2GHz (HT enabled) 2GB Dual channel DDR 400 RAMS, 2 gigbit NICs (they cannot load balance each other though)

That was done on it last week precisely and the system didn't hang with me at all!

I was able to make similar things with solaris but I am not using solaris right now on any productive system.

You can through 40% of that work on windows server 2003 before it starts to hang intermittently.

I believe to solve the previous issues you have a choice between running your OS as a server (favoring background services over applications) or as a workstation favoring applications over services. Go to "system properties>Advanced tab>performance>settings>advanced tab>processor scheduling".

Reply Score: 2