Linked by Thom Holwerda on Sun 23rd Sep 2007 13:43 UTC
Ubuntu, Kubuntu, Xubuntu Just like Eugenia yesterday, I also upgraded my laptop's Ubuntu Feisty installation to Gutsy a few days ago. The upgrade process went completely awry, though, so I was forced to do a fresh install. Not a bad thing, as it gave me the opportunity to take a look at Ubuntu's soon-to-be-released Gutsy Gibbon with GNOME 2.20
Thread beginning with comment 273603
To read all comments associated with this story, please click here.
CPU Frequency
by HangLoose on Sun 23rd Sep 2007 14:55 UTC
HangLoose
Member since:
2007-09-03

Did you try this yet ? You could have a better battery life.

But since we are in this subject, the support for cpu_freq scalling was almost like giving birth to an elephant. Is it better ?

Reply Score: 1

RE: CPU Frequency
by leech on Sun 23rd Sep 2007 20:23 in reply to "CPU Frequency"
leech Member since:
2006-01-10

All you have to do on a debian based system for cpu-freq to work is run 'dpkg-reconfigure gnome-applets' or on Ubuntu 'sudo dpkg-reconfigure gnome-applets' then it'll explain why it's not available in the first place, and give you a warning about it running SUID, then once you enable it, just add the CPU Frequency Scaling applet to your panel and it works. At least it does for both my AMD64 Desktop and my Intel Centrino Laptop. I did notice that Fedora 7 has this enabled by default.

Reply Parent Score: 3

RE: CPU Frequency
by mjg59 on Mon 24th Sep 2007 00:31 in reply to "CPU Frequency"
mjg59 Member since:
2005-10-17

CPU frequency scaling is handled by default. We don't support manual overriding out of the box because:

a) it's difficult to do in a way that doesn't allow denial of service, and
b) the kernel generally knows better than you, especially now that the ondemand governor is well tuned.

The only machines where it won't work automatically are Celerons (which don't support voltage scaling, so there's little point in frequency scaling) and some older Pentium 4s (which have similar issues, with the addition of extra latency to make the experience even worse). If you're having problems with another chip, please do file a bug.

Reply Parent Score: 2

RE[2]: CPU Frequency
by leech on Tue 25th Sep 2007 00:45 in reply to "RE: CPU Frequency"
leech Member since:
2006-01-10

Yeah, that's basically what I said ;) Fedora 7 has manual override on by default, under Debian and Ubuntu you have to reconfigure the gnome-applets to set SUID for manual override and it does give the appropriate warning.

Sometimes I like to use it when I'm watching a movie on my laptop while using my battery so that it doesn't use it all up, since usually to make smooth DVD playback, the CPU tries to jack itself up to maximum, even though the 798Mhz that it runs as the slowest speed works. Though I have found that under Windows XP, there was a slower speed that the CPU could clock itself too, and I had it working under Linux as well at one point, but I had to modify some files which I can't recall at the moment.

Reply Parent Score: 2