Linked by Thom Holwerda on Tue 5th Feb 2008 20:50 UTC
KDE KDE 4.0.1 has been released. "The KDE Community today announced the immediate availability of KDE 4.0.1. KDE 4.0.1 is a maintenance release which provides corrections of problems reported using the KDE bug tracking system and enhanced support for existing and new translations." Here's the changelog.
Thread beginning with comment 299552
To read all comments associated with this story, please click here.
Not Working!
by jlacroix on Wed 6th Feb 2008 02:34 UTC
jlacroix
Member since:
2006-08-30

4.0.1 just became available in the Kubuntu repositories, and now since I "upgraded" to it, almost none of my KDE4 apps will even load. What gives?

Reply Score: 1

RE: Not Working!
by Erunno on Wed 6th Feb 2008 07:47 in reply to "Not Working!"
Erunno Member since:
2007-06-22

"Works-for-me"(tm) on openSUSE with the KDE/KDE4/STABLE/Desktop repository. Maybe there's a problem with the Kubuntu packages. The maintainers even backported the resizable panel from trunk :-)

Edited 2008-02-06 07:48 UTC

Reply Parent Score: 2

RE: Not Working!
by m_abs on Wed 6th Feb 2008 08:17 in reply to "Not Working!"
m_abs Member since:
2005-07-06

The problem might be that some of the binaries or .desktop-files were renamed in kubuntu packages, so all the KDE4 apps I had in favorites didn't work anymore since the entries didn't point to them anymore, so I had to readd the apps to favorites.

Edited 2008-02-06 08:17 UTC

Reply Parent Score: 1

RE[2]: Not Working!
by jlacroix on Wed 6th Feb 2008 13:51 in reply to "RE: Not Working!"
jlacroix Member since:
2006-08-30

It definitely is a packaging problem with Kubuntu. It's just very annoying that they botched the packages.

Reply Parent Score: 2

RE: Not Working!
by fernandotcl on Wed 6th Feb 2008 14:53 in reply to "Not Working!"
fernandotcl Member since:
2007-08-12

If you're talking about the apps in the "Favourites" tab, apparently the location of the KDE4 binaries was changed to /usr/lib/kde4/bin. Remove the apps from your "Favourites" tab and add them again and they should work fine. If it still doesn't work, delete ~/.kde4 (all your settings and things like ktorrent's torrents will be lost, though).

If you're using kdm-kde4 as well, you might want to edit /etc/init.d/kdm-kde4 and replace genkdmconf-kde4 with /usr/lib/kde4/bin/genkdmconf and make sure that /etc/X11/default-display-manager says "/usr/lib/kde4/bin/kdm".

Other than that, I found an annoying bug in Konqueror that asked me to save all links, even links to regular web pages. But it seems to be fixed in 4:4.0.1-0ubuntu2~gutsy1~ppa1 (released a couple of hours later).

Let's not forget this is really a packaging problem, and also that this isn't even an official Kubuntu repository.

Reply Parent Score: 1

RE[2]: Not Working!
by jlacroix on Wed 6th Feb 2008 16:57 in reply to "RE: Not Working!"
jlacroix Member since:
2006-08-30

The Kubuntu logo is placed right on the Kicker menu. Looks official to me.

Reply Parent Score: 1

RE[2]: Not Working!
by anda_skoa on Wed 6th Feb 2008 18:52 in reply to "RE: Not Working!"
anda_skoa Member since:
2005-07-07

If it still doesn't work, delete ~/.kde4 (all your settings and things like ktorrent's torrents will be lost, though).

Which is why one should never even suggest this.

At most suggest to rename/move .kde4/share/config which at least keeps the user data in share/apps intact (Mails, contacts, calendars, bookmarks, etc.)

As a rule of thumb never suggest an option you wouldn't use yourself because of the potential consequences.

Reply Parent Score: 2