Linked by Thom Holwerda on Thu 10th Dec 2009 19:52 UTC
Graphics, User Interfaces For as long as I can remember, I've been having issues with scrolling in Windows and its applications. When scrolling via dragging the scroll blob, it seemed as if Windows had the annoying habit of randomly resetting your scroll blob to its starting position, which irritated me to no end. It took me a while to figure out, but I finally know when this behaviour occurs - now I just need to know: why?!
Thread beginning with comment 398901
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE[2]: XFCE
by Jimbo on Thu 10th Dec 2009 20:53 UTC in reply to "RE: XFCE"
Jimbo
Member since:
2005-07-22

In Windows all you have to do is SHIFT-Click to go to where you click in the scrollbar.


Interesting. Apparently KDE 4.3 behaves the same way.

Reply Parent Score: 2

RE[3]: XFCE
by AaronD on Thu 10th Dec 2009 21:10 in reply to "RE[2]: XFCE"
AaronD Member since:
2009-08-19

Why shift-click when you could use the MMB? ;)

Reply Parent Score: 1

RE[4]: XFCE
by cycoj on Thu 10th Dec 2009 23:10 in reply to "RE[3]: XFCE"
cycoj Member since:
2007-11-04

Thank you guys. I've been annoyed by this behaviour forever. I usually scroll up down in documents with the keyboard. However I often find myself wanting to go somewhere in a long document. Scrolling down with page-up/down takes forever, but clicking into the scrollbar just did the same thing. I never knew you could use the MMB or shift-click. Never thought of trying either.

Cheers
Jochen

Reply Parent Score: 1

RE[3]: XFCE
by Anonymous Coward on Fri 11th Dec 2009 11:49 in reply to "RE[2]: XFCE"
Anonymous Coward Member since:
2005-07-06

Is there a setting for this? It doesn't for me.... It does in Firefox, but not Konqueror, Dolphin, Kword or Arora... not Shif + Click, Nor CTRL or ALT + Click... I haven't tried anything else, and it's time for work.

Reply Parent Score: 1

RE[4]: XFCE
by lemur2 on Fri 11th Dec 2009 11:56 in reply to "RE[3]: XFCE"
lemur2 Member since:
2007-02-17

Is there a setting for this? It doesn't for me.... It does in Firefox, but not Konqueror, Dolphin, Kword or Arora... not Shif + Click, Nor CTRL or ALT + Click... I haven't tried anything else, and it's time for work.


You are correct.

In Firefox on KDE 4.3, shift-left-click, ctrl-left-click or middle click in the scroll bar margin = "jump" to that place proportionally.

In Dolphin or gwenview or other native KDE applications, shift and ctrl have no effect on clicks in the scroll bar margin. Middle-click alone works to "jump" to a place proportionally, while all left clicks (either with or without shift or ctrl) implement page up or page down.

For consistent behaviour, then, between GTK+ applications and native (Qt) applications under KDE4, use middle-click in the scroll-bar margin in order to jump.

Edited 2009-12-11 11:59 UTC

Reply Parent Score: 2