Linked by Thom Holwerda on Mon 10th May 2010 10:03 UTC, submitted by robertson
BeOS & Derivatives Two news items about alternative operating system news in a row? What is this, Christmas? In any case, the Haiku project, the darling of OSNews (hey it's okay now), has released its second alpha release. This new stable development release contains some serious improvements over the first alpha.
Thread beginning with comment 423880
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE: Haiku Alpha 2 FAIL...
by robertson on Tue 11th May 2010 19:23 UTC in reply to "Haiku Alpha 2 FAIL..."
robertson
Member since:
2010-04-30

Yet, Alpha 1 ran PERFECTLY on all these systems!

Anyone else having these types of problems?


I've been struggling to get it running on my IBM Thinkpad X30, which also runs Alpha 1 fine, albeit only in safe-mode VESA video (which doesn't bother me, it's still my monitor's highest supported, 1024x768). With Alpha 2, I've had it stop before ever getting to the blue screen and had it stop with a stuck pointer on the blue screen, depending on what "Safe Mode" options I chose.

I finally got the CD to boot all the way to the Live Desktop/possibility of install (haven't installed yet) by changing the following "Safe Mode Options" in the bootloader (hit the spacebar while the bootloader is displaying it's line of dots to get to the options screen):

I had to Disable DMA Mode, Use Safe Mode Video, and Disable ACPI.

I also had to go to the "Boot From Volume" sections and explicitly tell it to boot from only the CD-ROM (vs. Hard Drive or CD). Only then would it get past the stuck pointer on a blank blue screen.

I've had no luck whatsoever with USB sticks, only with a CD-R using the ISO image.

Hope that helps. I guess the moral of the story is to fiddle with the various booting options to see what works. I of course plan to file some bug tickets sometime soon. That's the whole point of Alpha releases, right? (:

Edited 2010-05-11 19:33 UTC

Reply Parent Score: 1

RE[2]: Haiku Alpha 2 FAIL...
by Luposian on Tue 11th May 2010 19:49 in reply to "RE: Haiku Alpha 2 FAIL..."
Luposian Member since:
2005-07-27

Stupid me... I completely forgot about the boot menu thing... I can get to that and see how that helps. Thanks for reminding me!

Reply Parent Score: 2