Linked by Thom Holwerda on Mon 7th Jun 2010 09:46 UTC, submitted by dmbkiwi
KDE "The latest in the 4.x series of the KDE Software Compilation is due to be released in early August 2010. With the first beta of this release recently unleashed, I thought I'd download the openSuse packages and see what 4.5 has got in store for us."
Thread beginning with comment 428765
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE[2]: ...I
by Hiev on Tue 8th Jun 2010 00:29 UTC in reply to "RE: ...I"
Hiev
Member since:
2005-09-27

I could agree with you, but when the problem is with Intel, NVidia and Ati, and compiz works well, I don't think the problem has to do with drivers.

Reply Parent Score: 2

RE[3]: ...I
by Fettarme H-Milch on Tue 8th Jun 2010 09:42 in reply to "RE[2]: ...I"
Fettarme H-Milch Member since:
2010-02-16

Have you compared the sources of KWin and Compiz to check whether both use the same principles to achieve similar looking effects?
I didn't and I guess you didn't, too.

Here's a play of thought:
Let's say Compiz uses OpenGL 1.3 for its effects and KWin uses OpenGL 2.1.
Both Compiz and KWin could be bug-free, but some driver handles OpenGL 1.3 better than OpenGL 2.1.

Of course, I don't know which is the actual reason for the performance discrepancies, however judging by past experience, drivers are likely to blame.
For NVidia GPUs, drivers older than v180 caused many problems with Qt4 and KWin. It was so bad, I installed a beta of v180 that regularly caused X to crash, but the way better performance weighted more.
Since then (1.5 or 2 or so years ago) Qt4, KWin, and Plasma is a smooth experience for me (GeForce 9200M).

I've read similar stories about the proprietary ATI drivers. I suggest to try recent FOSS ATI drivers that are reported to work well with window managers.

Intel had its fair share of problems as well when the internal driver architecture was changed. It caused performance regressions in all sort of areas.

Reply Parent Score: 4

RE[4]: ...I
by righard on Tue 8th Jun 2010 15:33 in reply to "RE[3]: ...I"
righard Member since:
2007-12-26

If OpenGL 2.1 than causes problems with almost all drivers, be it the drivers fault or not, maybe the Kde team should consider switching to OpenGL 1.3.

Reply Parent Score: 1

RE[4]: ...I
by Hiev on Tue 8th Jun 2010 17:00 in reply to "RE[3]: ...I"
Hiev Member since:
2005-09-27

Im not using ATI's propietary drivers, so that's not the problem, is anyone in the KWin world even investigating these problems?

Reply Parent Score: 2