Linked by Thom Holwerda on Thu 10th Jun 2010 12:53 UTC
Linux This is a problem I've been dealing with for a while now. I have a Lexmark printer which I've bought without checking for compatibility with Linux (I bought it when I was still using Windows), and as it turns out, this printer is not supported in Linux. I switched to Linux on my main desktop full-time late last year, so instead of to my desktop, I hooked this printer up to my bedroom Windows 7 media server/HTPC, and whenever I need to print, I just drop the file in question on this machine, and print form there. I need a better solution. Update: As it turns out, Lexmark has recently started releasing Linux drivers (good stuff). Still, the problem at hand stands, as there might still be other printers that suffer from the same problem.
Thread beginning with comment 429476
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE: drivers
by Thom_Holwerda on Thu 10th Jun 2010 13:15 UTC in reply to "drivers "
Member since:

Holy crap!

What in the name of.... They released this only a few months ago, I see. I have to admit that after checking every week between November and February I kind of stopped hoping. Nice stuff. Article still stands though: it's a problem others deal with too.

Trying out drivers...

EDIT: Nevermind. 32bit only. I'm on 64bit.

Edited 2010-06-10 13:18 UTC

Reply Parent Score: 1

RE[2]: drivers
by kvarbanov on Thu 10th Jun 2010 13:21 in reply to "RE: drivers "
kvarbanov Member since:

Thom, if it doesn't work, here's how I've done it - KDE3 and some HP printer floating around - tried the drivers - didn't work, dumped them. I added a new printer device from the KDE menu, and I've simply chosen RAW TCP printer type - I just entered the IP and the port, and voila, it was running like a charm. HTH in case you need that.

Reply Parent Score: 1

RE[2]: drivers
by woegjiub on Thu 10th Jun 2010 13:23 in reply to "RE: drivers "
woegjiub Member since:

Here is how to install the 32bit drivers on a 64 bit system.

Stupidly, even with the 32bit runtime, the package denies installation, so one merely needs to unpack it, and then run it.
It worked a treat with my X2650 in 10.04

Edited 2010-06-10 13:24 UTC

Reply Parent Score: 1