Linked by David Adams on Tue 20th Jul 2010 18:07 UTC, submitted by sjvn
SuSE, openSUSE Long time fans of openSUSE Linux and its commercial big brother, Novell's SUSE Linux Enterprise Desktop, will find a lot to like in this latest update.
Thread beginning with comment 434133
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE[2]: zypper
by vivainio on Tue 20th Jul 2010 21:07 UTC in reply to "RE: zypper"
vivainio
Member since:
2008-12-26

I have never had any problems with dependencies or conflicts with apt

I've had tons, not being able to install/download packages when dependencies are not available being a good example (you can --force-all dpkg, but not apt).

Reply Parent Score: 2

RE[3]: zypper
by sorpigal on Wed 21st Jul 2010 16:26 in reply to "RE[2]: zypper"
sorpigal Member since:
2005-11-02

Ugh, don't --force-all! You're asking for trouble by hiding problems you haven't seen yet. I know you meant --force-depends.

If you did in fact see a broken dependency problem you are either (1) tracking testing, (2) tracking sid, (3) performing an unsupported upgrade (e.g. skipping a major release), (4) using a third party repository, or (5) some combination. If encountered any of these scenarios I hope you filed a bug!

Edited 2010-07-21 16:35 UTC

Reply Parent Score: 3