Linked by Thom Holwerda on Fri 24th Sep 2010 23:20 UTC
Google A few days ago I dove into the lawsuit filed by Skyhook against Google, and came to the conclusion that Skyhook's case - while an entirely plausible sequence of events considering Google is a big company and hence prone to abuse - simply wasn't a very good one. Google's CEO Eric Schmidt has given a rather generic-looking statement on the matter, but however generic it may be, there's a hint in there.
Thread beginning with comment 442641
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE: good thing
by Morgan on Sat 25th Sep 2010 10:24 UTC in reply to "good thing"
Morgan
Member since:
2005-06-29

Well said. That's where Android is such a unique player in the mobile arena; the very fact that it is open allows anyone to take it and make it their own.

However, I personally feel that Google should lighten up a bit when it comes to their branded apps. Perhaps they should allow at least the search widget, maps and Gmail without restrictions.

The market is another story; I can see why they wouldn't want just any device to have access. For example, I just switched from BlackBerry to Android yesterday via the Motorola Cliq, a version 1.5 device. I chose that phone because I like the hardware, MotoBlur is fun, and Motorola has committed to a 2.1 upgrade soon (it's in the testing phase now). Regarding the Market, I have twice now installed an app that gave no warning about compatible OS versions, but when I try to run it, it says "This app is compatible with 2.x and above". One app simply closes immediately, the other falls back to a native OS app and only provides codecs (it's a video player).

To me, the above situation is just silly. This is one area where Apple's strict control over their app store is a good thing; no worries about which version of iOS a user has installed. Now, that doesn't mean I think Google should ban the Market from a non-blessed device; rather, I think they need to put more work into the Market itself to ensure that no incompatible apps show up on a particular device.

I know Android can be a techie's dream device, and techies tend to research apps and make sure they only install what works. However, Android is now a mainstream mobile OS and has more non-techie users by far today. These are the folks who will think their device or its OS is "broken" if it refuses to run apps. I know this for a fact as my co-worker has been very frustrated with her Droid Eris over unstable and non-functioning apps and has exchanged it twice. I tried to explain to her recently that there is an update to 2.1 that might fix those issues, but she is very hesitant to update the device and is instead waiting for a device upgrade on her contract.

I think over time Google will see these issues and work to correct them. They have far too much invested in Android at this point to ignore their huge customer base.

Reply Parent Score: 2

RE[2]: good thing
by kovos on Sat 25th Sep 2010 10:47 in reply to "RE: good thing"
kovos Member since:
2010-07-20

"I have twice now installed an app that gave no warning about compatible OS versions, but when I try to run it, it says "This app is compatible with 2.x and above""

As an Android developer i have to tell you that this happened just because the developer is a beginner.
Android DOES have an option to specify the minimum os version (Among other things like hardware requirements). If your device doesn't match those requirements it won't show in the market.
Source: http://developer.android.com/guide/topics/manifest/uses-sdk-element...

Regarding Apple i have to disagree with you because Android allows BOTH uncontrolled and controlled app stores. VCAST and the Lenovo app store are examples of Android app stores with strict application approval.
And this choice is what makes Android great in the first place.

Reply Parent Score: 3

RE[3]: good thing
by Morgan on Sat 25th Sep 2010 11:31 in reply to "RE[2]: good thing"
Morgan Member since:
2005-06-29

Thank you for the well-informed input! It's nice to know that there is version-limiting support in the Market. Shame on those developers for not researching and using this feature. Having said that, I think the video player developer did the right thing in allowing the app to download to 1.x devices so the user could at least make use of the codecs included. That was pretty cool of them.

In the 18 hours I've owned this phone -- six of which I've been asleep -- I've already found it to be the right combination of hardware and OS for me for the foreseeable future. I was holding out for the Nokia N900 but I just can't justify spending that much on hardware alone. It's the same conundrum I face as a low-income Apple fan; I love OS X but I can't afford a real Mac so I make do with commodity hardware. In the mobile space, I take advantage of on-contract discounts to get a phone I'm able to enjoy using, yet still afford those little luxuries like food and shelter. (For those without a sense of humor, that last bit was sarcastic.)

For all I know, Maemo could be a thousand times better than Android for someone like me, but I won't know because Android so far is an excellent fit for me. By the time I can afford the N900, the N910 (or whatever they decide to call it) will be out with MeeGo. I may dip into those waters in the future but I'm satisfied with what I have right now.

Reply Parent Score: 2