Linked by AdamW on Tue 23rd Aug 2011 22:10 UTC
Fedora Core Fedora 16 Alpha is released today, featuring GNOME 3.1.4 with a unified input indicator for keyboard layouts and input methods, KDE 4.7, GRUB 2 on new installations (with GPT disk labels) and several other major changes. You can download it now. Remember to read the important information in the release notes and common bugs page.
Thread beginning with comment 486569
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE: Ugly Font Rendering
by gilboa on Wed 24th Aug 2011 07:29 UTC in reply to "Ugly Font Rendering"
gilboa
Member since:
2005-07-06

... Not sure that this is the issue your hitting, but there's an issue with auto-hinting on some display / GPU configuration that makes Fedora 15 fonts look horrible on some machines (I hit it on my Laptop, but not on my workstations... go figure).

The solution is quite simple:
Create a file name 99-autohinter-only.conf in /etc/fonts/conf.d.

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<match target="font">
<edit name="autohint" mode="assign">
<bool>true</bool>
</edit>
</match>
</fontconfig>


Not sure if it works on F16 (I've yet to try it).

- Gilboa

Edited 2011-08-24 07:30 UTC

Reply Parent Score: 4

RE[2]: Ugly Font Rendering
by orestes on Wed 24th Aug 2011 13:31 in reply to "RE: Ugly Font Rendering"
orestes Member since:
2005-07-06

Cue Fred Sanford like heart attack claims whenever someone mentions text files and simple in the same sentence...

I've definitely seen the weirdness you're talking about though. On my system Fedora's got some of the best font rendering out of box of any OS I've seen. On my coworker's laptop it looks godawful by default until one applies the hinting change.

As for the people whining about the base font itself, you could, you know, take the two clicks or so and change it to one you prefer. It's not like we're in the dark old days of hand configuring X11 with Type 1 fonts

Oh, and the font hinting settings are accessible through Gnome-Tweak-Tool. Should be in the F16 repos if it's not installed by default

Edited 2011-08-24 13:33 UTC

Reply Parent Score: 2

RE[2]: Ugly Font Rendering
by AdamW on Wed 24th Aug 2011 16:21 in reply to "RE: Ugly Font Rendering"
AdamW Member since:
2005-07-06

Well, what that does is disable the bytecode interpreter and use autohinting only. It's a wonderful example of the subjectivity of font rendering, in fact. Here's the history.

The freetype autohinter is a workaround for the fact that bytecode interpretation (reading special instructions that come with a font which tell you how to hint it, essentially) was patented. Fedora is serious about known patents, so Fedora prior to F15 disabled freetype's bytecode interpreter and used autohinting only.

One of the #1 'fix Fedora's ugly font rendering' "tips" for Fedora 14 and earlier was to install a modified freetype package which enabled the bytecode interpreter.

Since F15 the patent on the bytecode interpreter is dead, so Fedora's freetype ships with the bytecode interpreter enabled. Autohinting is only used for fonts which don't have a bytecode. Now, one of the #1 'fix Fedora's ugly font rendering' "tips" is how to configure freetype to use the autohinter all the time - i.e. the precise opposite of the old "tip".

Need any more proof that this is an utterly subjective area? ;)

Reply Parent Score: 4

RE[3]: Ugly Font Rendering
by gilboa on Wed 24th Aug 2011 16:29 in reply to "RE[2]: Ugly Font Rendering"
gilboa Member since:
2005-07-06

Well, what that does is disable the bytecode interpreter and use autohinting only. It's a wonderful example of the subjectivity of font rendering, in fact. Here's the history.


Adam,

Being a long time Fedora user, I'm well aware of byte-code/auto-hinter story.
However, not sure if its DPI related or nVidia card related, when I hit this issue (as I said, I only faced this issue on ~50% of my Fedora 15 machines) there was nothing subjective about the fonts being incorrectly rendered.
E.g. On the machines that exhibit this issue, the vertical line in "L" in certain sizes is simply aliased out making L look like it underscore ("_").

Sadly enough, as I saw multiple posts about this issue back when I started using F15, I didn't file a bug report coupled with pictures.
I'm in the process of converting large number of F14 machines to F15; if one of them triggers this bug, I'll file a bug report w/ pictures.

- Gilboa

Reply Parent Score: 2