Linked by Thom Holwerda on Sat 17th Sep 2011 00:19 UTC
Linux "Many Linux distributions have taken the path of easy GUI-based installation, in order to appeal to a broader mix of users. But not Arch Linux, which emphasises simplicity of technical complexity over general usability. Richard Hillesley explains."
Thread beginning with comment 489904
To view parent comment, click here.
To read all comments associated with this story, please click here.
RaisedFist
Member since:
2005-07-06

so you come and post a video older than one year... things have changed and that was fixed.... pacman is one of the best package managers I've ever worked with.. and AUR works very well if you use one of the community built scripts (like packer or yaourt).


# pacman -Si gtk-qt-engine
Repository : extra
Name : gtk-qt-engine
Version : 1.1-2
URL : http://code.google.com/p/gtk-qt-engine/
Licenses : GPL
Groups : None
Provides : None
Depends On : libbonoboui kdelibs

Reply Parent Score: 7

lucas_maximus Member since:
2009-08-18

I suspected that it is fixed now (I didn't bother to check) ... but it shouldn't have got like that in the first place. Alarm bells should have been going off in that guys head when he was packaging it.

Reply Parent Score: 2

Laurence Member since:
2007-03-26

I suspected that it is fixed now (I didn't bother to check) ... but it shouldn't have got like that in the first place. Alarm bells should have been going off in that guys head when he was packaging it.

That's partly a result of not compiling the binaries yourself (you'd get similar issues with RPMs and Deb packages too). The solution is to compile your own source, but not everyone has the time, expertise nor motivation to do so.

Plus RPMs come with a whole boatload of other issues on top. So Pacman's only real rival is Debian's apt-get. Personally I prefer Pacman, but each to their own.

As for AUR, Yaourt is an awesome tool. It's the only thing I prefer to FreeBSD's ports for source.

Reply Parent Score: 3

_txf_ Member since:
2008-03-17

The Arch guys tend to say (somewhere, I guess it is in the wiki) that you should be wary of what you install and upgrade as it is a rolling release distro.

They do check, but sometimes things get missed and it is the responsibility of the user to make sure stuff works on their system (and downgrade if it doesn't)

Reply Parent Score: 3