Linked by Howard Fosdick on Wed 29th Feb 2012 00:56 UTC
Hardware, Embedded Systems Current computers use SATA disk drives. Pentium IV's and earlier computers used the IDE drive standards. How can you intermix SATA and IDE disk drives? This article discusses the options. It is the next in my series of articles on computer refurbishing.
Thread beginning with comment 509092
To read all comments associated with this story, please click here.
Further issues
by ingraham on Thu 1st Mar 2012 04:35 UTC
ingraham
Member since:
2006-05-20

First, thanks for the article. I found it very thorough and well written. Why anyone is complaining about a solid overview is beyond me.

Anyway, I have been working on this same problem recently and hit a snag that was not addressed. I have a new machine with SATA only. Occasionally I want to plug in old PATA drives, possibly even booting off of them. I have a removable rack in the front of the machine to make this easy.

I tried an IDE controller from Ultra and an IDE to SATA adapter similar to the Syba mentioned in the article. Both of them would lock up the system at boot time if there was no drive installed in the rack. It wasn't even an annoyingly long time out; they would NEVER allow the system to continue to boot. Anybody have any ideas?

Thanks,
James

Reply Score: 2

RE: Further issues
by Laurence on Thu 1st Mar 2012 08:40 in reply to "Further issues"
Laurence Member since:
2007-03-26

First, thanks for the article. I found it very thorough and well written. Why anyone is complaining about a solid overview is beyond me.

It was just a comment, not a complaint.


Anyway, I have been working on this same problem recently and hit a snag that was not addressed. I have a new machine with SATA only. Occasionally I want to plug in old PATA drives, possibly even booting off of them. I have a removable rack in the front of the machine to make this easy.

I tried an IDE controller from Ultra and an IDE to SATA adapter similar to the Syba mentioned in the article. Both of them would lock up the system at boot time if there was no drive installed in the rack. It wasn't even an annoyingly long time out; they would NEVER allow the system to continue to boot. Anybody have any ideas?

Thanks,
James

You have a dodgy converter. Replace it

Reply Parent Score: 2

RE: Further issues
by benali72 on Thu 1st Mar 2012 09:49 in reply to "Further issues"
benali72 Member since:
2008-05-03

If the IDE/SATA adapter doesn't work, it's probably defective hardware. I'd try another one. Since this is supposed to be copmletely transparent it should work on any system.

The controller card is harder to diagnose. It could be anything causing the problem, but most common is software driver compatibility issues.

Reply Parent Score: 1

RE[2]: Further issues
by ingraham on Sat 3rd Mar 2012 03:55 in reply to "RE: Further issues"
ingraham Member since:
2006-05-20

To benali72 and Laurence, I don't believe faulty hardware is the problem.The devices work.perfectly well IF A DRIVE IS PLUGGED IN. The failure condition is only when the system tries to boot with card / adapter powered and plugged in but with no drive attached. In the case of the PCI card by Ultra, tech support actually told me there was no way to make it work. It appears that the devices are not designed to deal with the scenario of booting without a drive connected. Before you say, "Why would anyone ever do such a stupid thing," believe me that I have a valid, reasonably frequent scenario where I normally boot without a drive but every once in a while boot from a PATA drive. It's in a business environment involving old but still-running machines using the QNX RTOS.

Thanks,
James

Reply Parent Score: 1