Linked by Thom Holwerda on Mon 12th Mar 2012 23:16 UTC
Windows Okay, so this one actually bothers me quite a deal in the Windows 8 consumer preview: the fonts in Metro look fuzzy - they look like fonts on Mac OS X. Because of the Mac OS X resemblance, I had assumed that Metro switched to a shape-accurate rendering method, like Mac OS X uses, but as it turns out, it's a little less exotic than that.
Thread beginning with comment 510392
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE: Comment by ssokolow
by mikeinohio on Tue 13th Mar 2012 12:44 UTC in reply to "Comment by ssokolow"
mikeinohio
Member since:
2010-02-21

If you have a problem with color fringing, that probably means that you are using an LCD display and your operating system does not have the LCD filter patches. Many Linux distributions do not include the LCD filter patches due to licensing issues, I believe.

It is actually pretty easy to apply the LCD patches. Just google "Debian font rendering" and replace "Debian" with whatever OS you are using for instructions.

I use Debian squeeze. In that case, I had to update Iceweasel to the latest version via Debian Backports and replace the fonts folder in the /etc/ directory. It took me about half an hour to do that. It was worth it though. Sub pixel rendering looks much better than greyscale when you have the LCD filter patches.

Reply Parent Score: 2

RE[2]: Comment by ssokolow
by Laurence on Tue 13th Mar 2012 13:11 in reply to "RE: Comment by ssokolow"
Laurence Member since:
2007-03-26

If you have a problem with color fringing, that probably means that you are using an LCD display and your operating system does not have the LCD filter patches. Many Linux distributions do not include the LCD filter patches due to licensing issues, I believe.

It is actually pretty easy to apply the LCD patches. Just google "Debian font rendering" and replace "Debian" with whatever OS you are using for instructions.

I use Debian squeeze. In that case, I had to update Iceweasel to the latest version via Debian Backports and replace the fonts folder in the /etc/ directory. It took me about half an hour to do that. It was worth it though. Sub pixel rendering looks much better than greyscale when you have the LCD filter patches.

I can't speak for GNOME, but KDE has this built into it's control panel. So it's a simple mouse button click to turn on or off.

Reply Parent Score: 2

RE[3]: Comment by ssokolow
by Ardour on Tue 13th Mar 2012 20:32 in reply to "RE[2]: Comment by ssokolow"
Ardour Member since:
2012-03-13

This is not what he is talking about. This is desktop environment independent issue, subpixel font rendering is available and there is an option, but it's horrid without filter patches (horrible colour fringing, hinting), which are for freetype. I am KDE user myself and I had to get freetype from separate repo to have nicely looking fonts on my distro.
As far as I know Ubuntu have these patches enabled by default. I'm not sure what is the current state of this patent issue and if it's still present.

Edited 2012-03-13 20:34 UTC

Reply Parent Score: 2