Linked by Thom Holwerda on Wed 2nd May 2012 21:56 UTC
Windows A few days I switched back to Windows Phone 7.5 as my main smartphone operating system. Why? Well, because I can. I like to change things up every now and then, and blessed as I am with an iPhone 3GS (currently pulling duty at my best friend as her portable gaming device), Galaxy SII with CM9, and an HTC HD7, I have the luxury of doing so. Now that I'm back in the neat, tidy, and straight-lined arms of Windows Phone 7 - three long-standing issues really break the illusion, which all come from one source: the networking stack.
Thread beginning with comment 516878
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE: Comment by kaiwai
by Thom_Holwerda on Thu 3rd May 2012 08:54 UTC in reply to "Comment by kaiwai"
Thom_Holwerda
Member since:
2005-06-29

Interesting theory, but T-Mobile NL only uses 2100Mhz for 3G, which the HD7 supports.

It's really crazy. My brother's girlfriend and I both bought a 3GS in the same week, both on T-Mobile. We held the phones next to each other - hers had perfect 3G reception, mine had none. Same for my other phones. The moment I leave town - as in, almost accurate to the metre - I get my connection back.

It's insane, because outside of my hometown, my 3G connection is downright awesome. Elevators, buildings, it doesn't matter, it always works. Just when I'm in my hometown, it doesn't - no matter the phone.

Reply Parent Score: 1

RE[2]: Comment by kaiwai
by MOS6510 on Thu 3rd May 2012 10:46 in reply to "RE: Comment by kaiwai"
MOS6510 Member since:
2011-05-12

As a wise and holy man once said: hold it different.

Reply Parent Score: 2

RE[2]: Comment by kaiwai
by jal_ on Thu 3rd May 2012 13:31 in reply to "RE: Comment by kaiwai"
jal_ Member since:
2006-11-02

You did report this to T-Mobile, right?

Reply Parent Score: 2

RE[2]: Comment by kaiwai
by Morgan on Thu 3rd May 2012 18:07 in reply to "RE: Comment by kaiwai"
Morgan Member since:
2005-06-29

I've had intermittent networking issues with my HTC Arrive on Sprint, both on WiFi and EvDO. Not quite as bad as what you've described though; mostly the web browser inexplicably unable to load a site via either connection method while the PC I'm at, connected to the same WiFi network, has no problem. It's very random and has only happened a few times in the past six months I've had the phone.

I've also occasionally had live tile update issues, but only with certain third party apps and the "Me" social notification tile. My biggest gripe with WP7 is text messaging. The phone will not under any circumstances allow me to type out a SMS message with more than 160 characters. Every phone I've had in the past, on any carrier, would let me keep typing past the barrier and would break the message up into multiple ones if necessary. But WP7 on the Arrive will disable the "Send" button/icon if I go one character past the counter. I have to hit "Send" and quickly continue typing my message in a new text box. No other Sprint phone has this issue either, so it's strictly a WP7 problem.

As an aside, we have a Sprint femtocell at my full time job, as all of the deputies are issued Sprint phones and in the past we've had issues with reception due to the building design. So, I get a full five bars of EvDO reception anywhere in the building. The funny thing about it is that my download speed drops to about 150-200Kbps in the building, whereas at home with only two or three bars, I can get up to 800Kbps. Since our officers are issued voice-only dumbphones, I've often wondered if the femtocell is configured to prioritize voice over data.

Reply Parent Score: 2

RE[2]: Comment by kaiwai
by siimo on Sat 5th May 2012 00:16 in reply to "RE: Comment by kaiwai"
siimo Member since:
2006-06-22

Have you tried replacing your SIM? It sounds crazy but this happened to someone I know. Reception issues no matter what phone they used, but then they replaced their SIM card and it started working perfectly.

Reply Parent Score: 2