Linked by Thom Holwerda on Thu 3rd May 2012 22:36 UTC
Graphics, User Interfaces It's here: the GIMP 2.8. Its biggest feature is something that many, many people have been requesting for as long as I can remember: single-window mode. No longer do you have to fiddle with a gazillion palette and dialog windows (unless you choose to do so, of course). Great work by the team.
Thread beginning with comment 517050
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE: Cool
by chenxiaolong on Fri 4th May 2012 15:54 UTC in reply to "Cool"
chenxiaolong
Member since:
2011-12-05

I know you said that you would rather not compile anything, but it's actually quite easy to create DEB packages from the PPA for Ubuntu:

1. Download sources from http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu/pool/main/g.... The following command will download all the sources automatically (which are listed in the .dsc file):

dget http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu/pool/main/g...

2. Extract the tarballs:

dpkg-source -x gimp_2.8.0-1ubuntu0ppa3~precise.dsc
cd gimp-2.8.0

3. Create the DEB packages. The command will tell the exact packages/dependencies you need to install.

dpkg-buildpackage -us -uc -b

And the shiny new DEB packages will be in the same folder as the .dsc file ;)

Edited 2012-05-04 15:56 UTC

Reply Parent Score: 3

RE[2]: Cool
by backdoc on Fri 4th May 2012 17:03 in reply to "RE: Cool"
backdoc Member since:
2006-01-14

Great tip! I've been using Debian, as well as, Debian derivatives for years. I've never seen this. Unfortunately, it didn't work for me.

Not trying to turn this into a help forum, but here's the error message:

dget: using existing gimp_2.8.0-1ubuntu0ppa3~precise.tar.gz
gimp_2.8.0-1ubuntu0ppa3~precise.dsc:
dscverify: gimp_2.8.0-1ubuntu0ppa3~precise.dsc failed signature check:
gpg: keyblock resource `/home/backdoc/.gnupg/secring.gpg': file open error
gpg: Signature made Thu 03 May 2012 10:27:58 AM CDT using DSA key ID 5CA857DF
gpg: Can't check signature: public key not found
Validation FAILED!!

Reply Parent Score: 2

RE[2]: Cool
by UltraZelda64 on Sat 5th May 2012 01:19 in reply to "RE: Cool"
UltraZelda64 Member since:
2006-12-05

Right after extracting, I ran into problems. When trying to build the Debian package, I ran into a dependency problem.

I'm not going to go through this again--I don't know how many times I've desperately wanted to try a brand-new package and tried to compile after reading claims that "it's so easy". So I install one dependency... then find out that I have to install another one... and another... and another... and it goes on and on. By the time I've installed all required dependencies, it still doesn't work so I have to tweak compile options. And at the end, it may still not work, and I just give up. Meanwhile, that nice fresh OS installation now how dozens of useless packages installed and I lost track of what the hell they all are, so I can't just easily remove them all. I really do not want to go through that again.

I am actually running the latest Squeeze-based version of CrunchBang that tracks backports by default, freshly installed, and do not want to get it all dirty with development packages that will otherwise be useless. Just recently I was running the latest openSUSE, and before that Debian itself with a few backports.

Reply Parent Score: 2