Linked by Thom Holwerda on Thu 18th Apr 2013 22:59 UTC
Internet & Networking "As promised, this version leaves behind the older Internet Explorer 6, 7, and 8 browsers. In return it is smaller, faster, and can be used in JavaScript environments where the code needed for old-IE compatibility often causes problems of its own. But don't worry, the jQuery team still supports the 1.x branch which does run on IE 6/7/8. You can (and should) continue to use jQuery 1.9 (and the upcoming 1.10) on web sites that need to accommodate older browsers."
Thread beginning with comment 559207
To read all comments associated with this story, please click here.
...
by Hiev on Fri 19th Apr 2013 02:48 UTC
Hiev
Member since:
2005-09-27

To drop IE 6 and 7 is good, to drop IE8 is stupid.

Edited 2013-04-19 02:49 UTC

Reply Score: 4

RE: ...
by Gunderwo on Fri 19th Apr 2013 03:48 in reply to "..."
Gunderwo Member since:
2006-01-03

That's why they are continuing development on the 1.x branch as well. 2.0 requires a newish browser while 1.x will continue support and as IE8 usage dies so will usage of the 1.x branch.

Reply Parent Score: 3

RE[2]: ...
by Delgarde on Fri 19th Apr 2013 04:02 in reply to "RE: ..."
Delgarde Member since:
2008-08-19

Yeah, I think they've handled this pretty well. IE9 marks the point where it can be considered "good enough" to not need a lot of the previous special case handling.

Yes, IE8 is still used - some of my customers are only now upgrading to it as part of the migration away from XP - but for them, jQuery 1 is still there and maintained. And for the customers that *are* willing to run with IE9 as a minimum, we can get a little more efficiency by using jQuery 2.

Reply Parent Score: 3

RE: ...
by robojerk on Fri 19th Apr 2013 03:49 in reply to "..."
robojerk Member since:
2006-01-10

I agree. IE8 is as high as you can go with Windows XP, and there are still a lot of installations out there.

Reply Parent Score: 3

RE[2]: ...
by looncraz on Fri 19th Apr 2013 04:54 in reply to "RE: ..."
looncraz Member since:
2005-07-24

I agree. IE8 is as high as you can go with Windows XP, and there are still a lot of installations out there.


Right, except you can still use Chrome, Firefox, Opera, etc...

Reply Parent Score: 2

RE: ...
by lucas_maximus on Fri 19th Apr 2013 08:22 in reply to "..."
lucas_maximus Member since:
2009-08-18

TBH I think they will be keeping backward compatibility, so supporting older IE will be simply using a conditional tag.

Reply Parent Score: 2