Linked by Thom Holwerda on Mon 1st Jun 2009 17:50 UTC, submitted by poundsmack
Sun Solaris, OpenSolaris The team at Sun behind OpenSolaris has unleashed OpenSolaris 2009.06 upon the world. This new release comes packed with new features, changes, improvements, and fixes, and is the first release of OpenSolaris for SPARC, adding support for UltraSPARC T1, T2 (Sun4v), and UltraSPARC II, III and IV (Sun4u). Read on for some of the improvements that stand out.
Thread beginning with comment 366658
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE[6]: Pay or run unstable
by gjoahnn on Tue 2nd Jun 2009 16:27 UTC in reply to "RE[5]: Pay or run unstable"
gjoahnn
Member since:
2009-06-02

He is NOT lying, your information is inaccurate, please have a look at the Opensolaris Subscription Service FAQ, it has just been changed from

Q: If you download OpenSolaris, but do not purchase an OpenSolaris Subscription, what can you receive?
A: You can download OpenSolaris to obtain security and Device Driver fixes, but you are not entitled to any support.

( http://209.85.129.132/search?q=cache:Hg4LFWbFwXkJ:www.sun.com/servi... )

to now

Q: If you download OpenSolaris, but do not purchase an OpenSolaris Subscription, what can you receive?
A: You can download OpenSolaris and receive package updates via the community but you are not entitled to any support from Sun nor will you have access to the package updates from the Support Repository.

( http://www.sun.com/service/opensolaris/faq.xml#q4 )

Then take a look at http://blogs.sun.com/security/category/alerts , Opensolaris is not magically more stable than Linux. The /release branch of 2008.11 has a lot of serious security vulnerabilities (e.g. in ipfilter, OpenSSL or Firefox) which have been fixed in Solaris 10, /dev and subsequently 2009.06 but NOT in 2008.11 or 2008.05. At http://pkg.opensolaris.org/release/feed , you can easily see for yourself that neither 2008.05 nor 2008.11 have received security fixes.

For me that precludes any serious use without shelling out $300 for a support contract which many developers probably won't need.

Reply Parent Score: 1

RE[7]: Pay or run unstable
by akrosdbay on Tue 2nd Jun 2009 17:18 in reply to "RE[6]: Pay or run unstable"
akrosdbay Member since:
2008-06-09


Then take a look at http://blogs.sun.com/security/category/alerts , Opensolaris is not magically more stable than Linux. The /release branch of 2008.11 has a lot of serious security vulnerabilities (e.g. in ipfilter, OpenSSL or Firefox) which have been fixed in Solaris 10, /dev and subsequently 2009.06 but NOT in 2008.11 or 2008.05. At http://pkg.opensolaris.org/release/feed , you can easily see for yourself that neither 2008.05 nor 2008.11 have received security fixes.


Those are snapshots of the OpenSolaris development. You upgrade to the newest if you need the security fixes or just install the latest versions of the packages that need updating. Those are free. Upgrading an Opensolaris release is painless and with the automatic snapshot image-update does it is relatively easy to fall back.


For me that precludes any serious use without shelling out $300 for a support contract which many developers probably won't need.


You don't need it. You can install latest version of the packages or just upgrade.

Reply Parent Score: 2

RE[8]: Pay or run unstable
by gjoahnn on Tue 2nd Jun 2009 17:40 in reply to "RE[7]: Pay or run unstable"
gjoahnn Member since:
2009-06-02

"
Then take a look at http://blogs.sun.com/security/category/alerts , Opensolaris is not magically more stable than Linux. The /release branch of 2008.11 has a lot of serious security vulnerabilities (e.g. in ipfilter, OpenSSL or Firefox) which have been fixed in Solaris 10, /dev and subsequently 2009.06 but NOT in 2008.11 or 2008.05. At http://pkg.opensolaris.org/release/feed , you can easily see for yourself that neither 2008.05 nor 2008.11 have received security fixes.


Those are snapshots of the OpenSolaris development. You upgrade to the newest if you need the security fixes or just install the latest versions of the packages that need updating. Those are free. Upgrading an Opensolaris release is painless and with the automatic snapshot image-update does it is relatively easy to fall back.
"

I'm not sure what you're talking about here. Fact is, the original poster was right that you can either follow the /dev repository and get the development version (where security fixes are included) or buy a support contract and get security fixes for /release. You will however NOT receive security fixes for free if you stay with /release (have a look at the links I included).


"For me that precludes any serious use without shelling out $300 for a support contract which many developers probably won't need.


You don't need it. You can install latest version of the packages or just upgrade.
"

Note also that you cannot install *single* packages from a newer release in /dev. Of course you can update to /dev but then you run a development version with all consequences attached.

Reply Parent Score: 1

RE[8]: Pay or run unstable
by segedunum on Tue 2nd Jun 2009 22:36 in reply to "RE[7]: Pay or run unstable"
segedunum Member since:
2005-07-06

You don't need it. You can install latest version of the packages or just upgrade.

Backports of new software are a different kettle of fish, but people don't want to install the latest version of OpenSolaris just to get security updates. Every Linux distribution worth its salt is able to do that with its eyes shut.

For a company that seems to want to convince people to use OpenSolaris rather than all those Linux distributions that have ate its lunch, and build a 'community' around OpenSolaris in the process, then I find that slightly bizarre. But then, I'm not that surprised really.

Reply Parent Score: 2