Linked by Thom Holwerda on Tue 31st Aug 2010 22:28 UTC, submitted by poundsmack
KDE "KDE has released a series of updates to the Plasma Desktop and Netbook workspaces, the KDE Applications and the KDE Platform. This update is the first in a series of stabilization updates to 4.5.0, coming every month, as if delivered by a cronjob. 4.5.1 brings bugfixes and translation updates on top of KDE SC 4.5.0."
Thread beginning with comment 438932
To read all comments associated with this story, please click here.
fast_rizwaan
Member since:
2010-09-01

the blur effect introduced in 4.5 is 'eating up' the cpu with nvidia 'proprietary' drivers. Just disable blur effect if we need a good performaning desktop.

Though Blur Effect is awesome, but it makes the 'desktop awful'. even scrolling becomes sluggish.

one can see the 'increase cpu usage' just by enabling [x]blur, in kwin effects.

by the way is there an alternative GPU video card, which is good with KDE 4.5?

ATI cards used to crash a lot, I dumped them. Intel not enough performance.. nvidia has the kde compositing problem!

Is there a savior?

Reply Score: 1

Calipso Member since:
2007-03-13

ah, that would explain the issues I've been seeing. Now gotta figure how to turn off the blur effect

Reply Parent Score: 1

KAMiKAZOW Member since:
2005-07-06

In System Settings, obviously.

Reply Parent Score: 2

fast_rizwaan Member since:
2010-09-01

right-click on the titlebar -> Configure window behavior-> Desktop Effects ->All effects [tab] -> scroll down to "appearance section" and 'untick' the [ ] blur, effect.

Reply Parent Score: 3

Calipso Member since:
2007-03-13

booo, turning off blur still makes kde 4.5 unusable with effects turned on. Will have to dig around some more to figure out what's going on. Works fine without effects though.

And yes, using an nvidia card.

Reply Parent Score: 1

KAMiKAZOW Member since:
2005-07-06

Visit https://bugs.kde.org/show_bug.cgi?id=242985 and tell your GPU model and driver version.
The KDE people can't fix buggy closed source drivers but they'll add your configuration to a blacklist to automatically disable blur.

Reply Parent Score: 3

JRepin Member since:
2007-10-18

I'm currently using 4.5 with ATI Radeon 9600XT and open source drivers and the blur enabled and it works very well. Also works fine on a laptop with ATI Mobility Radepn HD 5470 and closed drivers. And when I was still using NVidia they usually were quite good with fixing bugs if you reported them. Just follow instructions here: http://www.nvnews.net/vbulletin/showthread.php?t=46678

Reply Parent Score: 2

Laurence Member since:
2007-03-26

The blur effect works fine with my nVidia card.

That said, I am running an i7 with 4GB RAM, so even Vista should run snappy.

Reply Parent Score: 2

poundsmack Member since:
2005-07-13

My S3 cards work very well under linux

Reply Parent Score: 2

lemur2 Member since:
2007-02-17

My S3 cards work very well under linux


As do my ATI cards.

Reply Parent Score: 2

Neolander Member since:
2010-03-08

ATI cards used to crash a lot, I dumped them. Intel not enough performance.. nvidia has the kde compositing problem!

Is there a savior?

Several options :
1/Use windows until support for your graphic card has become okay (it generally happens some years after the release of the product)
2/Just disable those silly compositing effects, it's an attempt by the Devil to distract you from your work ;)

Edited 2010-09-03 08:49 UTC

Reply Parent Score: 4

Laurence Member since:
2007-03-26

Several options :
1/Use windows until support for your graphic card has become okay (it generally happens some years after the release of the product)
2/Just disable those silly compositing effects, it's an attempt by the Devil to distract you from your work ;)

or 3/ use CompizFusion instead. (Loving the Devil's distractions comment too by the way).

Personally I don't have a problem with nVidia and KDE4.5; it runs really smoothly for myself. In fact, I've only ever had one graphics card (well onboard graphics chip) not recognised in Linux and that was down to ASUS rebranding the hardware so the chipset didn't register as the chipset it actually was (and you can hardly blame Linux for this). However - and perhaps ironically given the opening post - OpenSuse still detected it where every other distro didn't. The best thing was it only took a few months for the rest of the distros to follow suit.

So I guess what I'm trying to say is this: I keep hearing people complaining about Linuxes support for graphics cards, but I personally have never experienced any problems. I've had problems configuring Xorg for dual monitors and the silly non-standard rebrand described above. But aside that, I've been running Linux on the desktop for about 10 years and had every graphics card detected and running smoothly.

But then I'm not a gamer - I'm just a power user who likes his "Devil's distractions"

Reply Parent Score: 3