Linked by Thom Holwerda on Wed 5th Oct 2011 20:36 UTC, submitted by zizban
BeOS & Derivatives Oh gosh, finally news that's got nothing to do with patents or smartphones or the comparing of male sexual organs. Haiku news! Michael Lotz has added preliminary support for WPA to Haiku, taking the first steps towards making the Haiku wireless stack a lot more useful.
Thread beginning with comment 492280
To read all comments associated with this story, please click here.
wpa_supplicant simply.... can't!
by Luposian on Fri 7th Oct 2011 18:05 UTC
Luposian
Member since:
2005-07-27

I have an EeePC 1001PXD netbook and have just built the latest GCC4 build of Haiku with wpa_supplicant installed. Problem is, nothing happens. The network thing in the deskbar still says "No link" and, when I go to Network Preferences, it says "no networks found", in the Networks tab, even after selecting the wifi connection in the uppermost tab.

Does it simply not work, or do I have to manually configure it? How do I go about that exactly? The directions in the post are a little hard to understand, as far as how I run/use the ifconfig thing. Do I use the terminal? Is there an actual application called wpa_supplicant in the Applications/Preferences or something?

Edited 2011-10-07 18:06 UTC

Reply Score: 2

umccullough Member since:
2006-01-26

I have an EeePC 1001PXD netbook and have just built the latest GCC4 build of Haiku with wpa_supplicant installed.


Did you install wifi drivers for your devices? Due to licensing issues with wifi drivers and their firmware, many of them cannot be shipped in a "working" state with Haiku (blame your hardware manufacturers for this...)

So, if launch a terminal and run: "install-wifi-firmwares.sh" that should prompt you for the license agreements to download the firmwares.

If that still doesn't allow your wifi hardware to work, you may just be out of luck until a driver is available... you can always file a bug report and include the output of your hardware device listing.

Edit: see http://www.haiku-os.org/guides/daily-tasks/wireless for more info (note, it's currently outdated)

Edited 2011-10-07 19:58 UTC

Reply Parent Score: 2

Luposian Member since:
2005-07-27

The Ethernet portion of my system works fine. And the wifi portion shows up as a selectable option in the prefs, but it showing up doesn't mean it automatically works? So I still have to install a driver for it? Didn't realize that... will try what you suggested!

Reply Parent Score: 2