Linked by Thom Holwerda on Fri 13th Oct 2006 13:19 UTC, submitted by Valour
Mandriva, Mandrake, Lycoris "Though delayed for a while and later to market than most Mandriva fans would probably prefer, the new Mandriva Linux 2007 PowerPack Edition is finally here, nearly a year after the previous release. 2007 is typical Mandriva through and through: attractively themed in KDE, easy to install without skipping the technical details, a little bug-ridden here and there, and full of new and interesting software technologies. This release does have its own identity, though; not only has the standard theme been redesigned for the first time in several years, but this is the first Mandriva release to include a legal DVD movie player."
Thread beginning with comment 171513
To read all comments associated with this story, please click here.
2007 Free not your grandmother's distro
by alcibiades on Fri 13th Oct 2006 17:32 UTC
alcibiades
Member since:
2005-10-12

I'd just say, be careful.

I've so far done one upgrade from 2006, which left machine A unbootable and with no X config. It went into a loop on being unable to write the boot sector and only poweroff would allow rebooting. xorg-configure wouldn't generate a valid configuration, and not much wanting to do this by hand, I resorted to extracting the xorg.conf file from the Live boot in the end.

I've never had problems with upgrades like this with Mandriva in the past, but thinking it might be upgrading that was the issue, I did a clean install on another new machine B. Same issue with xorg, but at least Grub got installed.

Got One, and that both booted and installed OK on B. Then downloaded the rest of the install. Now discovered that the screensaver crashed X. Fixed this, and tried to launch KDE apps from Gnome. Dcop server errors and permission problems. They ran relatively OK as root from a terminal. Created new user, and ran KDE and that seems to work, and most of the apps seem to work. Is there something about the permissions in the home folder when you create a user during the install process, but not when you do it from a booted system? Working so far, but not terribly confident.

I've been using Mandrake and now Mandriva for years now, and have a lot of admiration for what they've done, and their difficulties and how they've worked through them, but have to say, if other people are having this sort of experience, it was released too soon.

And Etch...well, probably sooner or later that's the way to go. You cannot go through this stuff once a year.

Reply Score: 2

darkmind Member since:
2006-02-13

Concerning upgrade and xorg issue, it's mostly due to the Xorg 7.1, i.e modular xorg. 2 things have change at the same time :
1. xorg has been splitted in many differents packages
2. X binary change from /usr/X11R6/bin to /usr/bin and fonts moved from /usr/lib/X11R6/fonts to /usr/share/fonts.

This means that when you are doing an upgrade, some application needs to have their config files modified ( kdm/gdm, fontconfig ) because they will look for X binary or fonts in the wrong location.


I was thinking about something concerning the One issue. Could this be related to the fact as One is on a CD, permissions where defaulted to read-only ?

Reply Parent Score: 2