Linked by Thom Holwerda on Wed 21st Apr 2010 23:01 UTC
Linux The tools used to boot Linux are changing. Specifically, the Grand Unified Bootloader is now officially in maintenance mode only, and GRUB's developers have abandoned the original GRUB in favor of an entirely rewritten package, known as GRUB 2. Discover GRUB 2's new capabilities and how to use it.
Thread beginning with comment 420233
To read all comments associated with this story, please click here.
I don't care for it either
by Morgan on Thu 22nd Apr 2010 08:44 UTC
Member since:

GRUB2 has bitten me more than once. When Ubuntu 9.10 first came out, I tried it as the only OS on a system. GRUB2 wouldn't boot after a default install though. This left me uninterested in Ubuntu for a while. Strangely enough, Linux Mint 8 (based on ubuntu 9.10) worked fine on the same system.

Today, I have a triple-boot system with a mix of SATA and PATA drives. I have Mac OS X on the SATA (spare me the wagging fingers please) and Windows XP/Linux Mint 8 on a PATA. Long story short, GRUB2 took over the boot partition of my SATA drive, so I had to disconnect it during the Mint install. Now I must choose which drive to boot from using the BIOS boot selector; not TOO big a deal but I didn't have this issue with regular GRUB or LILO for that matter i.e. Slackware didn't touch the SATA drive during a test install.

Reply Score: 4