Linked by lopisaur on Fri 25th Jun 2010 22:21 UTC
Ubuntu, Kubuntu, Xubuntu Based upon a recent email to the X.Org developers' mailing list, Canonical is nearing the point of one of their goals for Ubuntu 10.10 of a rootless X Server, or being able to run the X.Org Server without root privileges.
Thread beginning with comment 431687
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE[8]: Big deal...
by phoenix on Sat 26th Jun 2010 22:57 UTC in reply to "RE[7]: Big deal..."
phoenix
Member since:
2005-07-11

An even simpler way to reproduce the issue is to use dd.

dd if=/dev/urandom of=/somefile bs=1M count=10000 can cause an X11 GUI (KDE, GNOME, Xfce, etc) on Linux to slow down to a crawl until the dd is done. Doing the same with a USB drive makes it even more noticeable.

The same test on a non-Linux system will not affect X11, though.

Reply Parent Score: 2

RE[9]: Big deal...
by Zifre on Sun 27th Jun 2010 01:07 in reply to "RE[8]: Big deal..."
Zifre Member since:
2009-10-04

I'm not sure where you're getting this...

I just ran in this command:

dd if=/dev/urandom of=test bs=1M count=10000

on Ubuntu 10.04 on a Core i3 530, which is relatively slow. I noticed no decrease in responsiveness whatsoever. I even tried playing an OpenGL game. The FPS dropped by a few frames, but it was not choppy or unresponsive at all.

Maybe it's just your particular system that has problems?

(Note: I'm not trying to say that there is a problem with X11. I'm saying that the problem doesn't exist, in Linux or X11.)

Reply Parent Score: 2

RE[10]: Big deal...
by phoenix on Sun 27th Jun 2010 01:33 in reply to "RE[9]: Big deal..."
phoenix Member since:
2005-07-11

Every system we try this on at work (Kubuntu 10.04, Kubuntu 9.10, Debian 5.0, Debian 4.0) will grind to a halt until the dd command is done. You can't CTRL+TAB to other windows (well, you can, but it takes 30-45 seconds to register the keypress), you can't load other apps, you basically just stare at the blinky HD light.

These are Intel P4, AMD Sempron, desktops and Intel Core2 Duo laptops, using ATi Radeon X-series PCie, nVidia something PCIe, nVidia onboard, and Intel onboard graphics.

Every system we try it on is affected, even our multi-core Opterons with 3Ware RAID controllers and no GUI (keyboard lag, 30s or more to ALT+F* switch consoles, etc).

Try it with a USB stick as the of= option to really cause havoc.

Our sys analyst is a RedHat guy, and he's avoided dd for years because of this issue (RedHat 7-9, Fedora something, RHEL 4/5).

The last time I tried this was to make a bootable ChromiumOS USB stick. Took 20 minutes to dd the stick ... during which time I could not use my desktop.

Reply Parent Score: 2