Linked by Thom Holwerda on Tue 31st Aug 2010 22:28 UTC, submitted by poundsmack
KDE "KDE has released a series of updates to the Plasma Desktop and Netbook workspaces, the KDE Applications and the KDE Platform. This update is the first in a series of stabilization updates to 4.5.0, coming every month, as if delivered by a cronjob. 4.5.1 brings bugfixes and translation updates on top of KDE SC 4.5.0."
Thread beginning with comment 439296
To view parent comment, click here.
To read all comments associated with this story, please click here.
Laurence
Member since:
2007-03-26

Well, I'm currently using windows + cygwin because of my new laptop, so I can tell that bleeding-edge graphic chips are still an issue on linux


My current laptop is bleeding edge too and works perfectly. But perhaps I've just been lucky over the years *shrugs*.

If it's any help to you, I'm currently running ArchLinux x86_64.

I did find that when I first got my laptop, the current ISO didn't have the latest ethernet drivers I needed so I had to download a nightly build or something (I can't recall off hand, but I have the details at home). But that was the full extent of my problems.

Edited 2010-09-03 10:07 UTC

Reply Parent Score: 2

Neolander Member since:
2010-03-08

In my case, on several distros (Fedora, OpenSuse, Pardus) and with default settings, X shows a pretty dark screen when launched, and then the computer becomes unresponsive (ie Ctl+Alt+Fx things won't work, power button won't shut the machine down, and so on).

Tried to update NVidia and intel drivers to the latest release, no luck. Tried to force X to use the nvidia proprietary driver, no luck (no card detected). Tried with intel, no luck either (same symptom). 640x480 generic driver (VGA ?) kind of works, but it's just useless (insanely high screen brightness that can't be changed, eats up a fully charged battery in less than 2 hours, no room on screen, ugliness).

So I'll just consider that support for my hardware is not ready yet ;) Some years ago, I'd have fought with the command line until it works, but now I'm tired of this : either it works out of the box/with simple fixes or it doesn't work.

Edited 2010-09-03 10:21 UTC

Reply Parent Score: 2

Laurence Member since:
2007-03-26

I had a simular problem but that was related to Xorg's crappy new hotplugging not detecting my keyboard.

So dumb question, but you've checked that you're keyboard is being identified?

IIRC I fixed by adding one line to xinitrc.conf

[edit: fixed broken engrish]

Edited 2010-09-03 10:34 UTC

Reply Parent Score: 2

fithisux Member since:
2006-01-22

I will tell it again and again and again. The problem is that gfx and other devices do not conform to a standard that would help create cross-OS drivers targeting the standard and not vendors. No matter how good are the programmers the Linux/Haiku/Solaris .... drivers will be crippled. We need one standard, like VESA, for capabilites exposed by the HW to the OS developer that should encompass GPUs and APUs (AMD's terminology). You just swap the GFX, not the drivers.

Reply Parent Score: 3