Linked by paolone on Fri 4th Jan 2013 20:56 UTC
Amiga & AROS Icaros Desktop, the popular distribution of the AROS Research Operating System, has recently released its version 1.5, a new milestone since it finally allows to run classic Amiga software and games on full screen or perfectly integrating them into the host AROS desktop.
Thread beginning with comment 547604
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE[5]: Comment by lucas_maximus
by Zbigniew on Sun 6th Jan 2013 22:08 UTC in reply to "RE[4]: Comment by lucas_maximus"
Zbigniew
Member since:
2008-08-28

I wanted to give Icaros a try - downloaded Live - and only the latest menu entry allowed to boot it at all. Choosing first or second one results in complaining of my monitor: "mode not supported (H:90.1 kHz, V:60.1 Hz). Then the machine seems to be hung (had to use hardware reset). Choosing the third one shows some boot messages, but stops loading on "[packet] couldn't open bsd.handler" message. The last one booted successfully - but it looks awful, of course, in 16 colours.

It doesn't seem to be prepared to run on somewhat older hardware - most probably it requires rather recent monitors to try it. When switched to rather modern Gateway monitor, I could see boot messages in all available boot modes - still it doesn't work.

Mobo Gigabyte GA-M56S-S3, Sempron64, ATI HD5450 (Tried also with Nvidia on that second monitor).
IMHO it could be somewhat better tested before making a release, and such "demanding" graphics modes shouldn't be used for "live", where I can't tweak configuration file - since it's written on DVD-ROM. It just either will work, or not (and this time it isn't).

Reply Parent Score: 2

paolone Member since:
2007-09-24

Have a look in the guide, chapter 2 IIRC.

You should be able to pass settings to kernel before downloading it, just choose a suitable boot line like

Icaros Desktop (Legacy 800x600 resolution)

and press E. Then have a look into this setting

VESA=800x600@60

and kill the @60 part, maybe this is forcing AROS to a video frequency your monitor does not support. To continue booting, press Ctrl+X.

Reply Parent Score: 1

Zbigniew Member since:
2008-08-28

Thanks, but it seems, that you didn't read my comment carefully enough.
I wrote, that using third setting my monitor, well, shows the messages, just OS stops boot process at some particular point. And no: removing "@60" didn't help. As I wrote: I tried Icaros also with the other monitor - which hadn't problems with the frenquencies - and Icaros didn't work there neither.

Anyway IMHO the default settings shouldn't be set to such demanding values, that without reading some manuals it's not possible to take a look at what Icaros offers. Quite opposite: it should have settings "easy for everyone" (well, for the most, at least...), and when one needs something more sophisticated, in such case - after the lecture of manuals etc. - he can change some command-line parameters, selecting higher frequency this way (or whatever).

Reply Parent Score: 2

ncafferkey Member since:
2006-09-15

You can add VESA graphics to the last mode by editing it and adding something like "vesa=1024x768". Possibly your system needs ATA DMA turned off.

Reply Parent Score: 1

Zbigniew Member since:
2008-08-28

No, it didn't change anything - but your suggestion made me compare all the boot config lines. Yes, when disabling DMA, I was able to run 3rd "mode" as well - still: the graphics remained as ugly, as in 4th one.

What a pity, that it's so cumbersome. IMHO it has been released to early (at least as "regular" release, with no "beta" neither "pre"), without being well-tested.

Reply Parent Score: 2