Linked by MOS6510 on Wed 17th Apr 2013 21:20 UTC
General Development "You often hear about how important it is to write 'readable code'. Developers have pretty strong opinions about what makes code more readable. The more senior the developer, the stronger the opinion. But, have you ever stopped to think about what really makes code readable?"
Thread beginning with comment 559148
To view parent comment, click here.
To read all comments associated with this story, please click here.
lucas_maximus
Member since:
2009-08-18

My point was that bools tend to have names that when plugged into an if statement make it almost read like English.

if(!String.IsNullOrEmpty(myString){
//some code.
}

I tend to use similar in other programming languages. For example in a JavaScript.

if(!isAnimating){
//some code.
}

I know Microsoft's own variable naming schemes can be a bit iffy in places. But it better with the newer version on .NET IMHO.

Edited 2013-04-18 18:28 UTC

Reply Parent Score: 2