Linked by Thom Holwerda on Sun 1st Mar 2009 17:26 UTC, submitted by kaiwai
Hardware, Embedded Systems Long-time OSNews reader Kaiwai has written down his experiences with his Acer Aspire One, Linux, and Windows. He concludes: "After a hectic few weeks trying to get Linux to work, I am back to square one again - a netbook running Windows XP SP3 as it was provided by Acer when I purchased it. I gave three different distributions a chance to prove themselves. I expected all three distributions to wipe the floor with Windows XP - after all, these are the latest and greatest distributions the Linux world have to offer. There has been at least 7 years since the release of Windows XP for Linux to catch up to Windows XP and from my experience with Linux on this said device - it has failed to step up to the plate when it was needed."
Thread beginning with comment 351256
To view parent comment, click here.
To read all comments associated with this story, please click here.
RE[2]: I don't get this one
by lemur2 on Mon 2nd Mar 2009 03:38 UTC in reply to "RE: I don't get this one"
Member since:

The fact that you just said you simply needed to compile a driver should tell you exactly why Linux distros need polish. You should not need to compile a driver. Ever. You may need to _install_ a driver, but you should never need to compile one on a modern os unless, of course, you're the one developing the driver in question. But a system designed for an end-user should not need a compiler installed at all. Not for drivers, and not for applications--and the applications issue is mostly taken care of with software repositories which is a concept I do very much appreciate. The driver situation, on the other hand, is still a down right mess which doesn't look like it's going to get any better.

While I agree with your point here, the actual situation is not as dire as may have inadvertently been painted.

I also bought an MSI Wind U100, and I also tried to put Ubuntu 8.10 on it. At first the wireless card was not recognised. I found out the wireless card installed, which was RTL8187Se, and I found out that while Realtek had Linux drivers available for most of their chips, this particular card was not one of them. Realtek were still working on it, but some development code was available.

I knew that the MSI Wind was available with SuSe, so I looked at what SuSe had supplied with the MSI Wind. It was Realtek's development code for this card. No wonder that MSI had experienced a high return rate for Linux ... they were shipping a product with pre-release development versions of the driver. An alternative choice of any of several wireless cards would have saved MSI (and their users) all of this angst.

If I didn't know better, I'd almost suspect that they had deliberately picked a wireless card that had a dodgy Linux driver.

Anyway, after a while the community pitched in, and improved on Realtek's development driver. Pretty soon after I had bought the U100, a more stable version of the code (which you still had to compile for yourself) was available:

A week or so later ... binary packages were available for Ubuntu. Just download a .deb file and install with gdebi.

I believe this issue has gone away now with the release of Mandriva 2009.1 and Ubuntu 9.04 (the driver is now in the stock kernel), and of course it has always worked after a fashion with SuSe.

So as for the speculation "is still a down right mess which doesn't look like it's going to get any better" ... in actual fact this particular issue has already got better.

Edited 2009-03-02 03:52 UTC

Reply Parent Score: 3